升级你的 Flutter 版本

640?wx_fmt=jpeg

无论你使用哪个 Flutter 发布渠道,你都可以使用 flutter 命令来更新 Flutter SDK 和 app 所依赖的 packages。

1. 一次性设置

为了让 flutter 命令正确工作,你工程下的 pubspec.yaml 文件必须要求使用 Flutter SDK。

例如,下面的代码段指定了 flutter 和 flutter_test packages 依赖 Flutter SDK:

name: hello_world
dependencies:
  flutter:
    sdk: flutter
dev_dependencies:
  flutter_test:
    sdk: flutter

 请注意
不要使用  pub get  或  pub upgrade  命令来管理 Flutter apps 的依赖,而是使用  flutter pub get  或  flutter pub upgrade 。如果你想手动使用 pub,你可以通过设置  FLUTTER_ROOT  环境变量来直接运行。

2. 升级 Flutter SDK 和 packages

为了升级你 app 依赖的 Flutter SDK 和 packages,在 app 根目录执行  flutter upgrade  命令(与包含  pubspec.yaml  文件的目录相同):
640?wx_fmt=png
这个命令首先获取你的 Flutter 渠道可用的最新的 Flutter SDK 版本。接着这个命令更新你 app 依赖的每一个 package,到最新的兼容版本。
如果你想使用一个更加新的 Flutter SDK 版本,切换到不太稳定的 Flutter 渠道,并且运行  flutter upgrade
3. 切换 Flutter 发布渠道
Flutter 有 4个发布渠道,分别是 stable, beta, dev, 和 master。我们推荐使用 stable 渠道除非你需要更加新的版本。
要查看你当前使用的哪个渠道,使用下面的命令:
640?wx_fmt=png
要切换到其它渠道,使用  flutter channel <channel-name> 。当你切换了渠道以后,使用  flutter upgrade  下载 Flutter SDK 和依赖的 packages。例如:

640?wx_fmt=png

备忘 
如果你需要某个特定的 Flutter SDK 版本, 你可以从 Flutter SDK archive 页面下载。
4. 仅更新 packages
如果你已经修改了  pubspec.yaml  文件,或者你想仅仅更新你 app 依赖的 packages (而不是同时更新 packages 和 Flutter SDK)就使用  flutter pub  命令之一。
为了获取  pubspec.yaml  文件里列出的所有依赖,但排除不必要的更新,使用  get  命令:

640?wx_fmt=png

为了更新  pubspec.yaml  文件里列出的所有依赖到 最新的兼容版本 ,使用  upgrade  命令:

640?wx_fmt=png

5. 获得最新通知
我们将在 Flutter announcements mailing list  上发布重大更改的公告。你也可以在 Flutter dev mailing list  上提问!除了订阅接收公告外我们很乐意听取您的意见!
链接:
https://groups.google.com/forum/#!forum/flutter-dev
6. 选择特定版本
如果你想切换到特定版本的 Flutter,你可以使用  flutter version  命令:

640?wx_fmt=png

要强制使用某版本的 package,请在  pubspec.yaml  文件中指明其版本。
我们会将最新的 breaking change (重大改动) 通知到  Flutter 通知邮件群组 ,与此同时,你可以在  Flutter 开发者邮件群组  里向大家提问等。 我们希望得到你的反馈!
Flutter 通知邮件群组:
https://groups.google.com/forum/#!forum/flutter-announce
Flutter 开发者邮件群组:
https://groups.google.com/forum/#!forum/flutter-dev

640?wx_fmt=png

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: Age of Ai 设计师:meimeiellie 返回首页